Quick Reference

Sunday, August 31, 2008

RIP V2 SIM (New)

CCNA 640-802 CCNP
LAB: RIP V2
Question#
Central Florida Widgets recently installed a new router in their office (NEW_RTR). Complete the network installation by performing the initial router configurations and configuring RIP V2 routing using the router Command Line Interface (CLI) on the NEW_RTR .

Click on image for larger picture
Configure the router per the following requirements:
1) Name of the router is NEW_RTR
2) Enable-secret password is cisco
3) The password to access user EXEC mode using the console is class
4) The password to allow telnet access to the router is class
5) IPV4 addresses must be configured as follows:
5.1) Ethernet network 209.165.202.128 /27 – Router has the last assignable host
address in subnet.
5.2) Serial Network is 192.0.2.16 /28 - Router has the last assignable host
address in subnet.
6) Interfaces should be enabled.
7) Router protocol is RIPv2



Explanation:
Step1:
Click on the console host, you will get a pop-up screen CLI of Router.
Router>
Configure the new router as per the requirements provided in Lab question
Requirement 1:
Name of the router is NEW_RTR
Step2:
To change the hostname of the router to NEW_RTR follow the below steps
Router>
Router>enable
Router# configure terminal
Router (config)# hostname NEW_RTR
NEW_RTR(config)#


Requirement 2:
Enable-secret password is cisco
Step3:
To set the enable secret password to cisco use the following command
NEW_RTR(config)#enable secret cisco

Requirement 3:
The password to access user EXEC mode using the console is class
Step 4:

We need to configure the line console 0 with the password class
Also remember to type login command after setting up the password on line con 0 which allows router to accept logins via console.
NEW_RTR(config)# line con 0
NEW_RTR(config-line)#password class
NEW_RTR(config-line)#login
NEW_RTR(config-line)# exit
NEW_RTR(config)#


Requirement 4:
The password to allow telnet access to the router is class
Step 5:
To allow telnet access we need to configure the vty lines 0 4 with the password class
Also remember to type login command after setting up the password on line vty 0 4 which allows router to accept logins via telnet.
NEW_RTR(config)# line vty 0 4
NEW_RTR(config-line)#password class
NEW_RTR(config-line)#login
NEW_RTR(config-line)# exit
NEW_RTR(config)#


Requirement 5:
5.1) Ethernet network 209.165.202.128 /27 – Router has the last assignable host
address in subnet.
5.2) Serial Network is 192.0.2.16 /28 - Router has the last assignable host
address in subnet.

Step 6:
Ethernet network 209.165.202.128 /27 – Router has the last assignable host address in subnet.

Ethernet Interface on router NEW_RTR is Fast Ethernet 0/0 as per the exhibit

First we need to identify the subnet mask
Network: 209.165.202.128 /27
Subnet mask: /27: 27 bits = 8 + 8 + 8 + 3
=8(bits).8(bits).8(bits) .11100000 (3bits)
=255.255.255.11100000
=11100000 = 128+64+32+0+0+0+0+0
= 224
Subnet mask: 255.255.255.224

Different subnet networks and there valid first and last assignable host address range for above subnet mask are
Subnet Networks :::::: Valid Host address range :::::: Broadcast address
209.165.202.0 :::::: 209.165.202.1 - 209.165.202.30 ::::: 209.165.202.31
209.165.202.32 :::::: 209.165.202.33 - 209.165.202.62 ::::: 209.165.202.63
209.165.202.64 :::::: 209.165.202.65 - 209.165.202.94 :::::: 209.165.202.95
209.165.202.96 :::::: 209.165.202.97 - 209.165.202.126 :::::: 209.165.202.127
209.165.202.128 :::::: 209.165.202.129 - 209.165.202.158 :::::: 209.165.202.159
209.165.202.160 :::::: 209.165.202.161 - 209.165.202.190 :::::: 209.165.202.191
209.165.202.192 :::::: 209.165.202.193 - 209.165.202.222 :::::: 209.165.202.223
209.165.202.224 :::::: 209.165.202.225 - 209.165.202.254 :::::: 209.165.202.255
Use above table information for network 209.165.202.128 /27 to identify
First assignable host address: 209.165.202.129
Last assignable host address: 209.165.202.158
This IP address (209.165.202.158) which we need to configure on Fast Ethernet 0/0 of the router using the subnet mask 255.255.255.224

NEW_RTR(config)#interface fa 0/0
NEW_RTR(config-if)#ip address 209.165.202.158 255.255.255.224

Requirement 6:

To enable interfaces
Use no shutdown command to enable interfaces
NEW_RTR(config-if)#no shutdown
NEW_RTR(config-if)#exit

Step 7:
Serial Network is 192.0.2.16 /28 - Router has the last assignable host address in subnet.
Serial Interface on NEW_RTR is Serial 0/0/0 as per the exhibit
First we need to identify the subnet mask
Network: 192.0.2.16 /28
Subnet mask: /28: 28bits = 8bits+8bits+8bits+4bits
=8(bits).8(bits).8(bits) .11110000 (4bits)
=255.255.255.11100000
=11100000 = 128+64+32+16+0+0+0+0
= 240
Subnet mask: 255.255.255.240

Different subnet networks and there valid first and last assignable host address range for above subnet mask are
Subnet Networks ::::: Valid Host address ::::::::::: Broadcast address
192.0.2.0 :::::: 192.0.2.1 - 192.0.2.14 ::::::: 192.0.2.15
192.0.2.16 ::::::: 192.0.2.17 - 192.0.2.30 ::::::: 192.0.2.31
192.0.2.32 :::::::: 192.0.2.33 - 192.0.2.46 :::::: 192.0.2.47
and so on ….

Use above table information for network 192.0.2.16 /28 to identify
First assignable host address: 192.0.2.17
Last
assignable host address: 192.0.2.30

We need to configure Last assignable host address (192.0.2.30) on serial 0/0/0 using the subnet mask 255.255.255.240

NEW_RTR(config)#interface serial 0/0/0
NEW_RTR(config-if)#ip address 192.0.2.30 255.255.255.240


Requirement 6:
To enable interfaces
Use no shutdown command to enable interfaces
NEW_RTR(config-if)#no shutdown
NEW_RTR(config-if)#exit


Requirement 7:
Router protocol is RIPv2
Step 8:
Need to enable RIPv2 on router and advertise its directly connected networks
NEW_RTR(config)#router rip
To enable RIP v2 routing protocol on router use the command version 2
NEW_RTR(config-router)#version 2
Optional: no auto-summary (Since LAB networks do not have discontinuous networks)
RIP v2 is classless, and advertises routes including subnet masks, but it summarizes routes by default.
So the first things we need to do when configuring RIP v2 is turn off auto-summarization with the router command no auto-summary if you must perform routing between disconnected subnets.

NEW_RTR (config-router) # no auto-summary

Advertise the serial 0/0/0 and fast Ethernet 0/0 networks into RIP v2 using network command

NEW_RTR(config-router)#network 192.0.2.16
NEW_RTR(config-router)#network 209.165.202.128
NEW_RTR(config-router)#end

Step 9:
Important please do not forget to save your running-config to startup-config
NEW_RTR# copy run start
Any questions are welcomed on above LAB...
Best of Luck!!!!!

25 comments:

Brandon said...

Question #1
TELNET AND CONSOLE
Do you need to type in login in before you type passowrd? Is that important

When configuring EIGRP is considered worng on the test if type in. network 192.0.2.0
network 209.165.202.0 ?

no auto summary is this really optional?
I really don't understand no auto summary conmmand could you explain.


copy run start if you don't key this is your answer counted wrong?

I took the test on Sat 08/30 made 678

I did not do a copy run start on any of the labs. Were these ques counted wrong because of this?


Thank you for taking the time to read all of this. This is a great blog. I have seen about 10 ques exactly the same on the test

thanks b

a3tips said...

Hi,

Saving your work at SIMs is compulsory.. i.e copy run start

Hope this helps


Cheers!!!

Anonymous said...

I took the CCNA today and passed with 940/1000 thanks to the great information and explanation on this site.

I got the RIP v2 SIM, VTP SIM. Unfortunately, I didn't remember all the commands for the VTP SIM.

Thank you for all the help!!!!

Gerald said...

Could you explain how you came up with first assignable as 192.0.2.17 and last assignable as 192.0.2.30 i understand how to get the entire range for the network but how are you calculating the first and last assignable having a hard time understanding this.

a3tips said...

Hi Gerald,

If you can out the network range then you have almost knew the range of IP address that can be used and first assignable and last assignable

Explanation example :

If this is the network
192.0.2.16 - 192.0.2.31
Then 192.0.2.16 is Network address
192.0.2.31 is Broadcast address

The range of assignable address for the above network starts from
192.0.2.17 to 192.0.2.30

Since the network and broadcast address can not be assigned to any interface.

So the first assignable address is 192.0.2.17
The last assignable address will be 192.0.2.30

Hope this helps

Cheers!!!

Anonymous said...

This perfect site helped me pass the exam with 964 this morning. Thanks for your invaluable info guys.
But one thing I still don't understand that if we have to enter copy run start or not. 'Cause I haven't done that command for my 2 labs and I still passed (as the report shown).
The other thing is that the ip addr that you are asked to assigned to particular interface varies, i.e first, second.. or last. In my case, they asked for the fourth usable addr in the range. Be aware of that guys.
In VTP lab, there was a question about what destination MAC addr of an IP addr (not a MAC addr as usual) and I'm not sure if I did it wrong.
And I had only 48 questions in 90 mins.
Again thank you and good luck guys

peejay said...

hello a3tips,
really appreciate what you are doing...my question concerns the network statements configure under rip:if configured like this are this also acceptable?
router rip
network 192.0.2.0
network 209.165.202.0
will this also work as it is configure at the network boundaries?

adechius said...

Thanks for all your efforts, i relly i appreciate your work on this site.i sat for CCNA score 810.pls could you give solve on EIGRP sumilation in the exam i could not attempt this exam.Thanks

a3tips said...

Hi peejay,

You can also use those network statement it will work.

since we are using RIP V2 its good practise to use exact ntw to advertise in network command

Hope this helps
Cheers!!!

a3tips said...

I will try to update the EIGRP one this weekend

Cheers

Anonymous said...

Thanx 2 you, ur blog has helped me pass ccna today.....your sim explanations helped me a lot....keep up the gud work.....sreevtr

Anonymous said...

Hi,

I passed my ccna yesterday with 916 point. I acknowledge your site has been a huge help for me.

May God prospers you and your family.

Thanks a lot.

Do you know any great site like yours for the ccnp?

titi
Seattle, washington

Anonymous said...

there's an eigrp lab in the exam. wheres yours?

a3tips said...

I was busy at my work place.. Will update EIGRP Sim in next two days

Cheers!!!!

Tre said...

I like to add my name to list of folks that were able to pass the CCNA test by using this site.

I only got an 860; but I missed 2 questions because of nerves and 1 because I hit the "next" button instead of the topology button.

I only had 44 questions but boy was is loaded with Simulators and Topology questions.

But thanks a3tips for this site.

Anonymous said...

Got this Lab on todays exam .. (17th Sept 2009)

Cleared the Exam with full 1000 marks... All questions are from latest testinside n p4s.

Asad.

Anonymous said...

I had this SIM question along with the NAT SIM today. Passed the exam, thanks a lot for the detailed explanations in this site.

Anonymous said...

Oh man. I was so upset after the exam. I felt so lost after failing to understand the question similar to this.
Then I come home and find damn, I know this its all just subnetting.

Anonymous said...

thanks a lot
today I didn't passed my CCNA
and after, I found here all my sim.

Anonymous said...

I did not realize I had to save my configurations. Does this mean that every sim I did was counted wrong?
By the way, your site is GREAT! Lots of very useful information. Thank you,

ahmed said...

Thanks for this great site!!!!

Anonymous said...

Hi...a3tips, i gave my ccna yesterday and passed. i got this RipV2 sim ques, Frame-relay topology ques and ACL-NAT.
Apart from that there was que which had a topology structure with 2 routers and 2 hosts. Packets are transferred from RouterB to Router A, and they hav asked to drag matching IP address and MAC address, was bit confusing, hav not seen any model ques like that. I was sitting with that ques for long time and finally skipped it. If u get any idea out of this u can explain it to others.
Thanks a lot for this blog!!!

a3tips said...

Sure. I will update the blog with new info soon

Anonymous said...

Nice blog...Learned a lot from here...Today I passed CCNA...Thanks to a3tips..
I received
-ACL-Sim*
-EIGRP - Sim*
-DRAG and DROP
-Frame Relay*
-Simulation based on switch
and mainly Subnet questions*

*(available in this site)

Bee said...

I took my test on monday March 1st 2010, I had a same simulation but, They asked to assign 4th assign address from the range. I have passed the test.Test was time consuming. I have refer this blog like about four time and it has been really helpful.Keep up the good work.